Back to overview
Degraded

Contract List Unavailable for Large Accounts

Jun 18, 2026 at 6:50am UTC
Affected services
Web Application
API

Resolved
Jun 18, 2026 at 8:02am UTC

This incident has been resolved. Customers affected by the contract list and task list issue can now access their account as normal.

We apologize for the inconvenience.

Created
Jun 18, 2026 at 6:50am UTC

We have identified an issue affecting customers with a high number of contracts in their account. Impacted users may be unable to access their contract list and may see error messages after logging in.

What is affected:
Access to the contract list and task list for accounts with a large number of contracts. Other areas of the platform are not affected.

What we are doing:
We have identified the root cause — a database configuration change introduced yesterday evening. A fix is ready and is being deployed now. We will confirm resolution shortly.

What you need to do:
Nothing. Your data is safe and fully intact. Access will be restored automatically once the fix is live.

We will post an update as soon as the deployment is complete.